Forum › Forums › News › Announcements › antiX-25-full-beta1 for public testing › Reply To: antiX-25-full-beta1 for public testing
I encountered many problems with the runit services. Many services fail to start because “chpst” attempts to run “svlogd” with the “_runit-log” user, and the “_runit-log” user does not exist on the system. dnsmasq is an example of a service that fails to start because of this.
In addition, it seems that the dnsmasq installation package is buggy; it did not install the “/usr/share/dnsmasq/installed-marker” file, and the dnsmasq service will not start if this file does not exist. The dnsmasq installation package also did not install the “/var/log/runit/dnsmasq” folder, and the service will not start if this folder does not exist either.
I created the “_runit-log” user manually and created the missing folders and files, then the dnsmasq service started, but dnsmasq did not read the configuration files that I placed in the “/etc/dnsmasq.d” folder; the files were simply ignored.
Finally, I used the dnsmasq service normally with sysvinit in previous versions of antiX, but I’m unable to use it in this version of antiX.